Page 1 of 2

Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 8th, 2018, 10:19 pm
by kelownman
In early 2017, Chrome began prominently labeling certain insecure HTTP sites as “Not secure” in the address bar. Today, Google announced plans to mark all HTTP pages the same way on an upcoming version of the browser later this year.

Chrome 56 in January 2017 marked HTTP pages that collect passwords, credit cards, or other sensitive information with a “Not secure” label. Visible on the left of Chrome’s omnibar, this was aimed at conveying to users that their connection to a site might not be private.

In version 62, the warning was expanded to when users enter any data on an HTTP page, as well as on all HTTP pages in Incognito mode due to an increased expectation of privacy.

Google’s efforts continue with Chrome 68 marking all HTTP sites as “Not secure,” though the gray info icon remains for the time being. Back in 2016, the company noted that the plan is to eventually display an even more prominent red security indicator triangle.

Slated for release in July, this transition comes as 68% of all traffic on Android and Windows is now protected, while that number jumps to 78% on Chrome OS and Mac. The company also notes that 81 of the top 100 sites on the web use HTTPS by default.

https://9to5google.com/2018/02/08/googl ... ot-secure/

When will castanet and the forums get a secure web page? :D

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 8th, 2018, 10:28 pm
by GordonH
Never used Chrome, always had Safari never had a problem

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 8th, 2018, 10:57 pm
by Troy
kelownman wrote:When will castanet and the forums get a secure web page? :D

That actually already happened quite a while ago.
https://www.castanet.net
https://forums.castanet.net

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 9th, 2018, 5:46 am
by kelownman
well, thats interesting....it has always shown, on my chrome browser, as being "not secure" but NOW it shows both castanet proper and the forums as being "secure". well done! :up: :D

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 2:47 pm
by kelownman
This happened again and again...not sure why! Not sure if it is just chrome either, since I only use chrome for browsing.

Capture.JPG


When I press "refresh" nothing happens, other than to indicate the web page is "not secure". I know if I go to castanet.net, it will get the "secure" indicator and then I can go to forums.castanet.net and the page will show "secure" I have pressed "refresh" repeatedly, up to about 15 times when the page is "not secure" and the page would not change to "secure"

Is it a castanet issue or a chrome issue? strange behavior indeed.

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 2:54 pm
by oneh2obabe
Not sure what's happening - just logged in and it shows secure on my computer.
Untitled.png

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 3:25 pm
by ferri
kelownman wrote:This happened again and again...not sure why! Not sure if it is just chrome either, since I only use chrome for browsing.

Capture.JPG


When I press "refresh" nothing happens, other than to indicate the web page is "not secure". I know if I go to castanet.net, it will get the "secure" indicator and then I can go to forums.castanet.net and the page will show "secure" I have pressed "refresh" repeatedly, up to about 15 times when the page is "not secure" and the page would not change to "secure"

Is it a castanet issue or a chrome issue? strange behavior indeed.


Are you coming on initially from a saved link?

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 4:52 pm
by kelownman
yes, that is when I restart or start up the browser, it automatically loads twitter and forums.castanet.net from the previous time when I closed the browser.

It only happens, "not secure" message, when I have loaded the forum pages multiple times...so it would be secure for maybe 50 or 100 clicks or more and then the next click it would be "not secure", if that makes sense.

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 5:00 pm
by Bsuds
kelownman wrote:It only happens, "not secure" message, when I have loaded the forum pages multiple times...so it would be secure for maybe 50 or 100 clicks or more and then the next click it would be "not secure", if that makes sense.


Yup, it's telling you that you are spending way too much time in here! (like I can talk) lol

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 5:05 pm
by alanjh595
google Chrome has had a recent upgrade. Click on the the 3 "dots" in the upper right corner of Chrome and "update." Reboot and see if that works.

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 7:15 pm
by kelownman
yup, I updated the browser after I got the "not secure" message...although I thought I was up to date already...couldnt have been more than one step back though...

I will start the browser from scratch and enter the forums.castanet.net once the browser is loaded and see if that changes anything tomorrow morning. I have a feeling it wont...but....

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 7:34 pm
by Troy
kelownman wrote:I will start the browser from scratch and enter the forums.castanet.net once the browser is loaded and see if that changes anything tomorrow morning. I have a feeling it wont...but....

The link for the secure version of the forums is:
https://forums.castanet.net/

That will definitely get you to the secure site, always. If you go to just http://forums.castanet.net then you won’t get the secure version. I plan on putting in a permanent redirect from the non-secure forums to the secure version to prevent anyone else from experiencing any problems with this.

Troy

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 7:43 pm
by kgcayenne
I am curious, does Castanet.net have to pay extra for the secure URL?

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 7:44 pm
by kelownman
yes, I am aware of the http:// (not secure) and the https"// (secure)

I was definitely on the https:// web page...but after going from one forum header to another and 100 plus clicks, the page changed to http:// (not secure) and the only way to get back to secure was to click on the castanet icon to go back to the main page(secure) and then click on forums to be back on https://

Re: Chrome labeling HTTP sites as “Not secure”

PostPosted: Feb 12th, 2018, 8:06 pm
by Troy
Thank you very much for the further details. Now I need to find the link somewhere in the forums that’s taking you (and most likely others) to the non-secure version. Although, once the permanent redirect is in place that will solve the link issue as well.